SquirrelMail  
Donations
News
About
Support
Screen shots
Download
Plugins
Documentation
Sponsors
Bounties













Security Notice
Phishing campain
Version 1.4.15
Security Upgrade
Plugins - One-Time Password
Category: Logging in

This plugin is intended to decrease the risk of usernames and/or passwords being stolen when users log in to their accounts from untrusted locations. Users can create a list of usernames and/or passwords that will work one time only so that if stolen (during or after the login process), they would pose no security risk.

However, there are certain security tradeoffs associated with this functionality, so please be sure to read and understand the security information in the documentation.

Amongst other configurable settings, the administrator can decide to disable certain parts of the SquirrelMail interface when a user is logged in using a one-time password.


Version 1.0
by Paul Lesniewski on Sep 8, 2009
Please support this plugin's development: Donate to this author
[ otp-1.0-1.4.18.tar.gz tarball (2164 d/l) Help ]
Requires: SquirrelMail 1.4.18+, Compatibility plugin 2.0.9+, Optionally libmcrypt and the PHP mcrypt extension

Description: Initial release

Older versions

No older versions.

If you have problems with the download or decompressing...
Internet Explorer
Right-click on the file, then select "Save Target As"
Firefox, Mozilla, Netscape
Right-click on the file, then select "Save Link As"
Opera
Right-click on the file, then select "Save Link Document As"
Lynx and Links
Press "d" on the link to download the file directly.
  • Untarring problems: Your browser might have un-gzipped it for you automatically. Try just "tar xvf" instead of "tar xvfz". Also, the plugins archive isn't gzipped (it is a tarball of .tar.gz files)
  • Macintosh users: Just hold down your mouse button to get the menu instead of right-clicking.
  • If all else fails, seek our help
© 1999-2010 by The SquirrelMail Project Team