SquirrelMail  
Donations
News
About
Support
Screen shots
Download
Plugins
Documentation
Sponsors
Bounties













Security Notice
Phishing campain
Version 1.4.15
Security Upgrade
Plugins - Multilogin
Category: Logging in

This plugin displays a pull-down select box with IMAP server choices on the login page. The user will be logged in using the IMAP server that is chosen.

Make sure to download the Compatibility plugin in order for Multilogin to function correctly.


Version 2.4.2
by Paul Lesniewski on Feb 15, 2010
Please support this plugin's development: Donate to this author
[ multilogin-2.4.2-1.2.9.tar.gz tarball (3341 d/l) Help ]
Requires: Compatibility plugin version 2.0.12+, SquirrelMail 1.2.9+

Description:
  • Fixed typo in example configuration file

Older versions

Version 2.4.1
by Paul Lesniewski on Feb 14, 2010
[ multilogin-2.4.1-1.2.9.tar.gz tarball (1637 d/l) Help ]
Requires: Compatibility plugin version 2.0.12+, SquirrelMail 1.2.9+

Description:
  • Small, non-functional updates in documentation, example configuration file name, and addition of Gmail configuration example


Version 2.4
by Paul Lesniewski on Jul 27, 2008
[ multilogin-2.4-1.2.9.tar.gz tarball (3669 d/l) Help ]
Requires: Compatibility plugin version 2.0.12+, SquirrelMail 1.2.9+

Description:
  • Allow configuration file to be stored in main SquirrelMail config directory
  • Added patch for SquirrelMail 1.4.15
  • Redesigned some hook behavior to improve performance (also improves Login Manager (vlogin) performance)
  • Update for hook name change in SquirrelMail 1.5.2
  • Configtest: test if patch is applied
  • Other trivial updates


Version 2.3.4
by Paul Lesniewski on Dec 27, 2007
[ multilogin-2.3.4-1.2.9.tar.gz tarball (3369 d/l) Help ]
Requires: Compatibility plugin version 2.0.7+, SquirrelMail 1.2.9+

Description:
  • Added patch for SquirrelMail 1.4.12+
  • Miscellaneous cleanup, small internationalization updates and fixes
  • Update how cookie is created/destroyed
  • Added configtest test


Version 2.3.3
by Paul Lesniewski on Jan 16, 2007
[ multilogin-2.3.3-1.2.9.tar.gz tarball (4093 d/l) Help ]
Requires: Compatibility plugin version 2.0.5+, SquirrelMail 1.2.9+

Description:
  • Fixed compatibility with changed login_form hook positioning
  • Added ability to turn off ALL plugins in the disable_plugins setting
  • No more patching needed for SquirrelMail versions 1.5.2 and up.
  • Added patches for SquirrelMail versions up to 1.4.9 and 1.5.1.
  • Changed patches to apply from plugin directory
  • Added compatibility with 1.5.2 codebase, including templatized output
  • Minor code cleanup


Version 2.3.2
by Paul Lesniewski on Oct 20, 2005
[ multilogin-2.3.2-1.2.tar.gz tarball (5890 d/l) Help ]
Requires: SquirrelMail 1.2.9, Compatibility plugin

Description:
  • Code cleanup
  • Added patch for SquirrelMail 1.4.4.
  • Removed $IMAPServerSelectionText and $rememberServerText configuration settings in favor of standardized internationalization. If you need to change these strings, hard code them in functions.php or (better) create a correct translation locale file (even English is OK) with your changes.
  • Added "settingsWithEmbeddedPHP" setting for $IMAPSelections array that allows any configuration setting's value to contain embedded PHP code. If your configuration file previously contained the org_title setting overrides, you MUST add this as described in the docs!
  • Added error message when invalid server is specified (Thanks to April Lorenzen )


Version 2.3.1
by Paul Lesniewski on Aug 3, 2004
[ multilogin-2.3.1-1.2.tar.gz tarball (6289 d/l) Help ]
Requires: SquirrelMail 1.2.9, Compatibility plugin

Description:
  • Fix for php errors introduced in v2.3


Version 2.3
by Paul Lesniewski on Aug 2, 2004
[ multilogin-2.3-1.2.tar.gz tarball (3072 d/l) Help ]
Requires: SquirrelMail 1.2.9, Compatibility plugin

Description:
  • Fix for enabling plugins that use the same hook as Multilogin or Vlogin
  • Updated patch file for recent SquirrelMail releases
  • New background color for server selection portion of screen


Version 2.2
by Paul Lesniewski on Jul 5, 2003
[ multilogin-2.2-1.2.tar.gz tarball (5991 d/l) Help ]
Requires: SquirrelMail 1.2.9, Compatibility plugin

Description:
  • New approach to the "session_recall" functionality; hopefully all config overrides will be loaded more reliably. The source patch is now limited to one line in one file, instead of a line in almost every source file. This is a substantial change; upgrade is highly recommended
  • Added ability to change org_title in browser title bar
  • Added ability to enable and disable individual plugins on a per IMAP server basis


Version 2.1
by Paul Lesniewski on Apr 5, 2003
[ multilogin-2.1-1.2.9.tar.gz tarball (3919 d/l) Help ]
Requires: SquirrelMail 1.2.9, Compatibility plugin

Description:
  • Added ability to offer to remember which IMAP server the user last logged into
  • Fix (hopefully?) for usage with PHP v4.3
  • Updated session_recall patches for SquirrelMail versions 1.2.11 and v1.4
  • Minor HTML fix
Make sure to download the Compatibility plugin in order for Multilogin to function correctly.

Version 2.0
by Paul Lesniewski on Mar 15, 2003
[ multilogin-2.0-1.2.9.tar.gz tarball (3607 d/l) Help ]
Requires: SquirrelMail 1.2.9, Compatibility plugin

Description:
  • Now works with SquirrelMail version 1.4.0 (cvs)
  • New setup.php format for better overall SquirralMail performance


Version 1.0
by Paul Lesniewski on Feb 13, 2003
[ This version is not available. You might be able to get it by asking on the "squirrelmail-plugins" mailing list or by contacting the author. ]
Requires: SquirrelMail 1.2.9

Description: Initial release. Original plugin idea and code by Benoit Bourdin [bennyben at fleming.u-psud.fr].

If you have problems with the download or decompressing...
Internet Explorer
Right-click on the file, then select "Save Target As"
Firefox, Mozilla, Netscape
Right-click on the file, then select "Save Link As"
Opera
Right-click on the file, then select "Save Link Document As"
Lynx and Links
Press "d" on the link to download the file directly.
  • Untarring problems: Your browser might have un-gzipped it for you automatically. Try just "tar xvf" instead of "tar xvfz". Also, the plugins archive isn't gzipped (it is a tarball of .tar.gz files)
  • Macintosh users: Just hold down your mouse button to get the menu instead of right-clicking.
  • If all else fails, seek our help
© 1999-2010 by The SquirrelMail Project Team